Discussione:
BUG di access?
(troppo vecchio per rispondere)
Miaooo
2004-10-02 21:02:23 UTC
Permalink
ciao

mi e' capitato piu volte, lavorando con le maschere e relativo codice
vb, che una maschera funzioni perfettamente...ma poi basta una piccola
modifica al suo codice vb....che smette di funzionare e non si apre
nemmeno piu! oppure manda in crash proprio access quando cerco di aprirla...

cosi mi tocca a copiare i controlli del form in un nuovo form...e poi
copiare il codice a mano...e poi misteriosamente funziona tutto..eppure
ho solo copiato in una nuova maschera tutti i controlli e il codice
associato. :/


sono dei bug secondo voi?

ciao
Simone Calligaris
2004-10-02 21:20:55 UTC
Permalink
Post by Miaooo
mi e' capitato piu volte, lavorando con le maschere e relativo codice
vb, che una maschera funzioni perfettamente...ma poi basta una piccola
modifica al suo codice vb....che smette di funzionare e non si apre
nemmeno piu! oppure manda in crash proprio access quando cerco di aprirla...
cosi mi tocca a copiare i controlli del form in un nuovo form...e poi
copiare il codice a mano...e poi misteriosamente funziona tutto..eppure
ho solo copiato in una nuova maschera tutti i controlli e il codice
associato. :/
Può capitare, ma non con frequenza: ti consiglio di disabilitare
l'autocorrect da Access 2000 in avanti, crea molti problemi.
Miaooo
2004-10-02 21:24:38 UTC
Permalink
Post by Simone Calligaris
Può capitare, ma non con frequenza: ti consiglio di disabilitare
l'autocorrect da Access 2000 in avanti, crea molti problemi.
grazie del consiglio. gentilissimo

ciauz
Miaooo
2004-10-02 22:10:54 UTC
Permalink
e cmq ora mi funziona....ma appena ho modificato il codice...incollando
nell'editor del codice preso da un altro form...ecco che subito mi
crasha...al momento dell esecuzione del codice!!!

ma come cazz si fa a lavorare cosi...

scusate lo sfogo ma non si puo lavorare 10 crash al giorno
inspiegabili..dovuti solo all aver incollato del codice vb in un editor
!!!!!!!!!!!!!!!


non usero piu access dopo questo db

saluti
Simone Calligaris
2004-10-03 08:22:23 UTC
Permalink
Post by Miaooo
scusate lo sfogo ma non si puo lavorare 10 crash al giorno
inspiegabili..dovuti solo all aver incollato del codice vb in un editor
!!!!!!!!!!!!!!!
Concordo: non si può lavorare così ... ma la situazione in oggetto è molto
lontana dalla realtà.
Post by Miaooo
non usero piu access dopo questo db
Cerca però di essere più serio: non penserai che chi posta in questo ng.
abbia problemi simili ai tuoi ... se così fosse, nessuno userebbe Access.

Riformatta il PC, reinstalla Access, fa quello che vuoi ... ma,
cortesemente, non fare il Troll.

Ciao, Simone
Miaooo
2004-10-02 21:22:44 UTC
Permalink
Post by Miaooo
sono dei bug secondo voi?
ciao
leggendo altri post vedo che tutti consigliano proprio di importare
oggetti e codice su un nuovo form..

deduco quindi che per qualche motivo oscuro..la maschera si corrompa...e
son costretto a importare tutto su altra maschera :(

mi sa che e' l'ultimo programmino che faccio in access :) troppi casini

ciauz
Cinzia
2004-10-03 08:44:25 UTC
Permalink
Post by Miaooo
Post by Miaooo
sono dei bug secondo voi?
ciao
leggendo altri post vedo che tutti consigliano proprio di importare
oggetti e codice su un nuovo form..
deduco quindi che per qualche motivo oscuro..la maschera si corrompa...e
son costretto a importare tutto su altra maschera :(
mi sa che e' l'ultimo programmino che faccio in access :) troppi casini
ciauz
Ciao,
in effetti è abbastanza strana la frequenza con cui ti si verificano questi
problemi, hai installato tutte le service pack?
Saluti
Cinzia
Miaooo
2004-10-03 13:13:31 UTC
Permalink
Post by Cinzia
Ciao,
in effetti è abbastanza strana la frequenza con cui ti si verificano questi
problemi, hai installato tutte le service pack?
Saluti
si ...aggiorno sempre il pc....ma il fatto e' che mi da gli stessi
problemi anche su altri pc che uso, e non sono l'unico ad avere problemi
simili a quanto vedo.

io non sputo certo su access, che secondo me e' un ottimo strumento, e
se c'e molta gente che lo usa e' evidente che funzioni comunque bene a
parte questi errori..pero ripeto..non si puo lavorare con una
piattaforma con bug simili..rischiando di corrompere il database ad ogni
modifica che si fa.

mi dispiace per chi mi ha accusato di fare il troll(ho notato negli anni
che nei NG basta dire la propria opinione con un minimo di vivacita e
subito si vien etichettati come troll) ma mi pare di aver semplicemente
esposto e discusso un problema reale di access che hanno anche altri, e
ho solo detto che come programmatore non mi sento piu di lavorare con un
ambiente cosi labile e affetto da questo tipo di crash.

credo che per piccolo db, access vada bene. ma quando il lavoro diviene
consistente, sto notando piu di qualche bug.
Il fatto purtroppo e' che sono dei bug che si verificano semplicemtne
cambiando due righe di codice..o incollando qualche istruzione...mi pare
un po troppo labile come ambiente.

saluti
Simone Calligaris
2004-10-03 15:09:08 UTC
Permalink
"Miaooo" <
Post by Miaooo
io non sputo certo su access, che secondo me e' un ottimo strumento, e
se c'e molta gente che lo usa e' evidente che funzioni comunque bene a
parte questi errori..pero ripeto..non si puo lavorare con una
piattaforma con bug simili..rischiando di corrompere il database ad ogni
modifica che si fa.
Decisamente non si può!
Post by Miaooo
mi dispiace per chi mi ha accusato di fare il troll(ho notato negli anni
che nei NG basta dire la propria opinione con un minimo di vivacita e
subito si vien etichettati come troll) ma mi pare di aver semplicemente
esposto e discusso un problema reale di access che hanno anche altri, e
ho solo detto che come programmatore non mi sento piu di lavorare con un
ambiente cosi labile e affetto da questo tipo di crash.
credo che per piccolo db, access vada bene. ma quando il lavoro diviene
consistente, sto notando piu di qualche bug.
Il fatto purtroppo e' che sono dei bug che si verificano semplicemtne
cambiando due righe di codice..o incollando qualche istruzione...mi pare
un po troppo labile come ambiente.
Attenzione Miaoo ... cerca di essere razionale e rileggere quanto ho
scritto.
Ti ripeto: se il prodotto funzionasse in quel modo, nessuno lo
utilizzerebbe.

E nessuno lo utilizzerebbe per progetti grossi e professionali.
Spiace far pubblicità a prodotti su un'area pubblica, però in questi casi
per chiarire le idee può valerne la pena:

http://groups.google.it/groups?q=calligaris+group:it.comp.appl.access&hl=it&
lr=&ie=UTF-8&group=it.comp.appl.access&selm=ujNJc.53409%24GQ3.1495956%40twis
ter2.libero.it&rnum=1

Ora, stabilito che questi sono problemi tuoi, cerca d'impostare la richiesta
in maniera diversa.
Non usare Access perchè preferisci qualcos'altro è razionale,
l'atteggiamento che stai tenendo lo è assai meno.

Ciao, Simone
giorgio rancati
2004-10-03 13:21:33 UTC
Permalink
Post by Miaooo
ciao
mi e' capitato piu volte, lavorando con le maschere e relativo codice
vb, che una maschera funzioni perfettamente...ma poi basta una piccola
modifica al suo codice vb....che smette di funzionare....
[CUT]

che versione di Access hai ? e con che service pack ?
versione di Windows ?

forse non è la stessa situazione ma anche a me capitava la stessa cosa.

Ciao Giorgio
Marco Antonioli
2004-10-04 08:13:42 UTC
Permalink
Post by Miaooo
ciao
mi e' capitato piu volte, lavorando con le maschere e relativo codice
vb, che una maschera funzioni perfettamente...ma poi basta una piccola
modifica al suo codice vb....che smette di funzionare e non si apre
nemmeno piu! oppure manda in crash proprio access quando cerco di aprirla...
cosi mi tocca a copiare i controlli del form in un nuovo form...e poi
copiare il codice a mano...e poi misteriosamente funziona tutto..eppure
ho solo copiato in una nuova maschera tutti i controlli e il codice
associato. :/
sono dei bug secondo voi?
ciao
Ciao a tutti.
Scusate.
Mi inserisco per portare la mia esperienza.
Mi è sucecsso in passato, A97, AK, non così frequentemente da decidere
di
abbandonare, ma è successo (cosi come è sempre successo con tutti i sw
che ho utilizzato).
Adesso sta succedendo più frequentemente del solito (A2K) e praticamente
sempre lavorando con supporti USB. Sarà un caso ?
MArco
--
Posted via Mailgate.ORG Server - http://www.Mailgate.ORG
Miaooo
2004-10-04 17:20:45 UTC
Permalink
Post by Marco Antonioli
Adesso sta succedendo più frequentemente del solito (A2K) e praticamente
sempre lavorando con supporti USB. Sarà un caso ?
MArco
grazie del tuo intervento.

mi trovo costretto a ripetere che siam tutti daccordo sul fatto che
access sia buono e che con acccess si possano fare programmi anche
professionali...ma purtroppo ci son funzionalita in cui i bug escono
fuori e sono evidenti.

io ora sto lavorando con oggetti word.application....e i crash purtroppo
sembrano essere irrisolubili...nonostante
patch..reinstallazioni...prove su altri pc...etc

purtroppo quest'oggetto mi serve parecchio..e i continui crash mi pare
costituiscano un bel problema...

mi sa che in questi casi...sia piu facile trovare altre soluzioni per
risolvere il problema..invece che inpuntarsi a capire perche access crasha


ciao
Simone Calligaris
2004-10-04 18:46:26 UTC
Permalink
"Miaooo" <
Post by Miaooo
io ora sto lavorando con oggetti word.application....e i crash purtroppo
sembrano essere irrisolubili...nonostante
patch..reinstallazioni...prove su altri pc...etc
purtroppo quest'oggetto mi serve parecchio..e i continui crash mi pare
costituiscano un bel problema...
mi sa che in questi casi...sia piu facile trovare altre soluzioni per
risolvere il problema..invece che inpuntarsi a capire perche access crasha
Premetto che non farò altri interventi dopo questo.

Un conto è sostenere che un'applicazione vada in crash dieci volte al
giorno, altro dire che di tanto in tanto può succedere.

In rapporto al discorso Word.application: con Access 'XP + Word XP (non
posso dire col 97 o 2000) ho un'applicazione che genera via automazione OLE
addirittura Fatture, con tanto di tabelle e tutto il resto ... tra i clienti
che lo sfruttano nessuno ha problemi.

Che dire?
Prendo atto di quanto ti capita, ma non illuderti che sia normale.

Ciao, Simone
Miaooo
2004-10-05 10:01:45 UTC
Permalink
Post by Simone Calligaris
In rapporto al discorso Word.application: con Access 'XP + Word XP (non
posso dire col 97 o 2000) ho un'applicazione che genera via automazione OLE
addirittura Fatture, con tanto di tabelle e tutto il resto ... tra i clienti
che lo sfruttano nessuno ha problemi.
Che dire?
Prendo atto di quanto ti capita, ma non illuderti che sia normale.
Ciao, Simone
e' esattamente cio che faccio io. fatture e parcelle varie...e funziona
egregiamente a parte i crash frequenti che non capisco in concomitanza
di cosa accadono.

sto facendo prove..fattosta che il codice che uso l'ho trovato in
internet su vari siti ed esempi, non che su msdn..


see u

Continua a leggere su narkive:
Loading...